Skip to main content

Updated Force.com IDE Fork

My improved Force.com IDE fork

I would argue it is rare that re-inventing the wheel is the better choice compared to just improving an existing solution - I'm looking at you Salesforce Extensions for VS Code - and so since Salesforce opened sourced their Force.com IDE I have been updating it to suit my needs, mostly to speedup development:

  • WSDL version 42
  • Ability to 'Disable 'Save to Server' dirty resource check'
  • Ability to 'Disable 'Save to Server' synchronize check'
  • Ability to 'Disable 'Save to Server' user confirmation check'

Update Site and Public Repo

Today a co-worker needed to get setup with SF development and so I have officially created a public repo and an update site for my version, just add the the below URL to your 'Help > Install New Software...' to get your copy.

https://raw.githubusercontent.com/danielsokolowski/idecore/master/eclipse-ide-update-site/site.xml

Pull requests welcomed: https://github.com/danielsokolowski/idecore.

Be legendary and do social like this post as that helps me immensely and do follow me on twitter: @danielsokolows.

Comments

Popular posts from this blog

Storing passwords in PuTTY

How to save SSH username/password for auto login in PuTTy The answer is you can't do it...at least in plain PuTTy. However there is an awesome fork with that let's you store the username and password and other additional features called KiTTy . So grab yourself a copy and +1 this if you do, thanks.

Softeher 'Error occurred. (Error code: 2)' sollution

Protocol error occurred. Error was returned from the destination server. The Softether server by default to run on port 443 , if you server also hosts normal https then 443 is already taken and so Softether can't bind to it. When you run `vpncmd` it attempts to connect, find an active port, but of course fails with 'Protocol error occurred. Error was returned from the destination server.' because it's not actually connecting to the vpn server. By default Softether also listens on 992 , 1194 , and 5555 so the sollution is to modify specify `localhost:5555` when executing the `vpncmnd`. If this has helped you feel free to comment or follow me on twitter @danielsokolows .

LightScribe Template Labeler for Windows 10

LightScribe Template Labeler installation "Operating System Inadequate" Issue Unfortunately 'LightScribe Template Labeler' installation will not work on Windows 8 and Windows 10 machines as the install simply will error out with 'Operating System Inadequate'. Trying to install using compatibility mode did not help. Installing LightScribe Template Labeler Workaround However if you simply copy the installed folder from an older machine like Windows 7 into your `C:\\Program Files (x86)\LightScribe Template Labeler`, create a shortcut, then the software will still happily work, see: http://answers.microsoft.com/en-us/windows/forum/windows8_1-performance/lightscribe-templatesimple-labeler-the-system-is/c2ebee28-bfb5-4aef-beb3-a43329561da8?db=5&auth=1 So you can install Windows 7 machine in a virtual machine, install 'LightScribe Template Labeler', and then copy the resulting folder to your Windows 8 or Windows 10 machine. For my own convenien...